Works on Ampere A1 Compute

The following catalog lists the packages that are preinstalled on the Oracle Cloud Developer Image and are available for Oracle Linux 8 from the specified repository.

Software Catalog for Arm on OCI

See the full list at amperecomuting.com

Oracle Instant Client

Version(s): 19
Pre-installed

MySQL Server Community Edition (CE)

Version(s): 8.0
Pre-installed

Oracle GraalVM Enterprise Edition (EE)

Version(s): 21.1
Pre-installed

Oracle Java Platforms SE Development Kit (JDK)

Version(s): 8, 11 (LTS),15, 16
Pre-installed

Java SDK for Oracle Cloud Infrastructure

Version(s): 1.32.2-1.el8
Pre-installed

Git

Version(s): 2.27.0
Pre-installed

GNU C Compiler

Version(s): 9, 10
Pre-installed

Apache Maven

Version(s): 3.5, 3.6

NGINX

Version(s): 1.14, 1.16, 1.18

Node.js

Version(s): 10, 12, 14
Pre-installed

Microsoft TypeScript

Version(s): 3.6.4
Pre-installed

Typescript and JavaScript SDK for Oracle Cloud Infrastructure

Version(s): 1.14
Pre-installed

PHP

Version(s): 7.2, 7.3, 7.4
Pre-installed

Python

Version(s): 3.6, 3.8, 3.92
Pre-installed

Python SDK for Oracle Cloud Infrastructure

Version(s): 2.31.2l
Pre-installed

Ruby

Version(s): 2.5, 2.6, 2.7
Pre-installed

Ruby SDK for Oracle Cloud Infrastructure

Version(s): 2.12.0
Pre-installed

Go

Version(s): 1.14
Pre-installed

Go SDK for Oracle Cloud Infrastructure

Version(s): 35.3.0
Pre-installed

Eclipse

Version(s): 4.16
Pre-installed

Glassfish J2EE JSP API implementation

Version(s): 2.3.4
Pre-installed

Jetty Java Webserver and Servlet Container

Version(s): 9.4.30
Pre-installed

Ansible

Version(s): 2.9.18
Pre-installed

Oracle Cloud Infrastructure Ansible Collection

Version(s): 2.16.0
Pre-installed

HashiCorp Terraform

Version(s): 0.14.7-1.el8
Pre-installed

Terraform provider for Oracle Cloud Infrastructure

Version(s): 4.15.0-1.el8
Pre-installed

CLI client for Oracle Cloud Infrastructure

Version(s): 2.21.3-1.el8
Pre-installed

Container Tools

Version(s): 2.0, 3.03
Pre-installed

Buildah

Version(s): 1.19
Pre-installed

Podman

Version(s): 3.0
Pre-installed

Datadog agent

Version(s): 7

NGINX Plus

Version(s): 24

Rancher

Version(s): 2.5.8

Jenkins

Version(s): 2.277.4